Save translation is taking a long time

Incident Report for OneSky

Resolved

This incident has been resolved.
Posted Oct 18, 2019 - 05:23 HKT

Monitoring

We are monitoring the results of the fix.
Posted Oct 17, 2019 - 19:44 HKT

Investigating

We are currently investigating this issue.
Posted Oct 17, 2019 - 18:07 HKT
This incident affected: Platform.